[RDD] Problem ubuntu 16.04 LTS

Wayne Merricks waynemerricks at thevoiceasia.com
Tue May 17 12:53:11 EDT 2016


Hi,

I finally had some free time to try this.  Installing on Ubuntu 16.04 is 
a bit more effort than normal because you can't use the Tryphon repos 
which means you have to install QT3 from source yourself because Ubuntu 
dropped QT3 in either 14.04 or earlier.

The install goes something like this:

1) Install all the dependencies of QT3 and Rivendell from source
2) Download the archive QT3 version
3) Compile and install that (you need to edit qmap.h and qvaluelist.h to 
include stddef.h)
4) Compile and install the mysql driver for QT3 (not compiled in normal 
configure & make)
5) Add QTDIR and others to your bash paths
6) Download Rivendell 2.13.0
7) Compile and install that (remember to make a script to create 
/var/run/rivendell, systemd init?)
8) Change MySQL to use MyISAM by default
9) Copy over and edit rd.conf to /etc
10) Copy over and edit rd-bin.conf to /etc/apache2/sites-available 
(remove allow from and use require granted)
11) Fix an SQL error in rdadmin/createdb.cpp and recompile, make install 
again
12) Figure out why importing audio instantly imports but doesn't 
actually do anything (0 audio in cart).

Things I've learnt in the past few hours:

1) Google is still your friend
2) apt-file search is my new favourite tool
3) checkinstall is an easy way to get deb files of QT3 and Rivendell so 
you don't have to compile on other machines

I have the debs for AMD64 based systems and a big apt install list of 
dependencies.

Once you get QT3 installed you can follow the normal install 
instructions for Rivendell from source that haven't changed since Debian 
6 with the exception of the Apache require granted thing and MySQL 
MyISAM (default_storage_engine)

If anyone needs any more info please get in touch,

Wayne


On 02/05/16 07:36, juan carlos navarro hernandez wrote:
> Los siguientes paquetes tienen dependencias incumplidas:
>  rivendell : Depende: libflac++6 (>= 1.3.0) pero no es instalable
>              Depende: libid3-3.8.3c2a pero no es instalable
>              Depende: librivendell (= 2.10.3-1) pero no va a instalarse
>              Depende: libsoundtouch0 (>= 1.7.1-3~) pero no es instalable
>              Depende: libqt3-mt-mysql pero no va a instalarse
>  rivendell-server : Depende: libflac++6 (>= 1.3.0) pero no es instalable
>                     Depende: libid3-3.8.3c2a pero no es instalable
>                     Depende: librivendell pero no va a instalarse
>                     Depende: libsoundtouch0 (>= 1.7.1-3~) pero no es 
> instalable
>                     Depende: libqt3-mt-mysql pero no va a instalarse
> E: No se pudieron corregir los problemas, usted ha retenido paquetes 
> rotos.
>
>
>
> _______________________________________________
> Rivendell-dev mailing list
> Rivendell-dev at lists.rivendellaudio.org
> http://caspian.paravelsystems.com/mailman/listinfo/rivendell-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://caspian.paravelsystems.com/pipermail/rivendell-dev/attachments/20160517/f60fde6e/attachment.html>


More information about the Rivendell-dev mailing list