[RDD] Appliance Versions...

Lorne Tyndale ltyndale at tyndaleweb.com
Tue Jun 28 14:43:05 EDT 2016


Gerard,

Are there any errors in /var/log/messages ?

Based on your troubleshooting with sound cards, it could be a sample
rate issue - especially if you happen to be using an onboard-sound with
intel-based chipset.  Sometimes the Rivendell daemons experience a
sample-rate mismatch with the intel chipsets, causing things to not work
properly.  The answer is to set the rate in the /etc/asound.conf file. 
This has been discussed before, but most recently back in February. 
See:

http://caspian.paravelsystems.com/pipermail/rivendell-dev/2016-February/023877.html

Also note that any time you make changes with either rdalsaconfig or by
editing the asound.conf file directly, those changes will not take
effect until you restart the Rivendell daemons.

Have you checked to make sure the sound card itself isn't muted or
turned down in alsamixer?

I also notice that in your message there is a mention of Jack ports. 
Are you trying to use Jack, ALSA, or both for your audio output?

And what audio resources are showing up in rdadmin?



> 
> Well cowboy as it turns out it wasn't a fundament error in the user ... ie me I am a newbie but not to computing and the radio station I am hoping to use this system in  is a charity run by volunteers so its learn or not use the system !
> 
> Update and maybe some helpful news 
> 
> So I did a clean appliance (6.6 plus 2.5.5)  install tested fine rebooted tested fine (I filmed it all)
> Installed the update rivendell 2.14.1-1 only nothing more went in to admin next  then in to rdairplay loaded the test tone it bummed out  it didn’t play the tone  closed Rivendell then tried to open rdairplay again daemons again so I changed the sound card output to a different one in rdalsaconfig it showed 3 analog sound devices no 1 to 3 all on the same irq
> 
> Used service Rivendell stop then start ... it worked it said ok ! 
> 
> Went into rdairplay loaded test tone ... it played but I had no sound I tried all the jack sockets on the board but no sound 
> 
> So I plugged in an old Microsoft sound system 80 via usb changed the setting rdalsaconfig to the system 80 and then tried to play the test tone I got the Frozen RDairplay  (never had that before) I took the option to kill Rivendell then did a service Rivendell stop then start  and hay presto test tone works I have sound 
> 
> So it would seam that the 2.14.1-1 dose something to the sound card settings when it updates and I would guess that it doesn't upset the sound card if it’s a ASI one and why it dosent show up for some people 
> 
> lets face it no one running a test system is going to go out and buy an ASI sound card until they know they need it and they are going to use Rivendell, I would have a very hard time getting the committee to release the funds to buy an ASI card full stop ...  
> 
> Hope this helps all 
> 
> Gerard
> 
> -----Original Message-----
> From: rivendell-dev-bounces at lists.rivendellaudio.org [mailto:rivendell-dev-bounces at lists.rivendellaudio.org] On Behalf Of Cowboy
> Sent: 27 June 2016 22:31
> To: rivendell-dev at lists.rivendellaudio.org
> Subject: Re: [RDD] Appliance Versions...
> 
> On Monday 27 June 2016 04:26:12 pm Gerard wrote:
> > "yum update Rivendell"  said yes when needed on the update Then did 
> > nothing at all apart from shut  centos 6.6 down switched pc off then 
> > on again then tried to open rdairplay ... daemons failed this says to 
> > me that there is a fundamental error in the appliance ver V Rivendell 
> > 2.14.1
> 
>  No, that's a fundamental error in the user not doing what has been stated,  and restated time and time again.
> 
>  After the update, but before any attempt to run it, you must open  rdadmin and do nothing, so that it can automagically correct/update  the database to something runable.
> 
> --
> Cowboy
> _______________________________________________
> Rivendell-dev mailing list
> Rivendell-dev at lists.rivendellaudio.org
> http://caspian.paravelsystems.com/mailman/listinfo/rivendell-dev
> 
> _______________________________________________
> Rivendell-dev mailing list
> Rivendell-dev at lists.rivendellaudio.org
> http://caspian.paravelsystems.com/mailman/listinfo/rivendell-dev


More information about the Rivendell-dev mailing list