[RDD] gam_server bug.....

Cowboy curt at cwf1.com
Sat Jun 25 09:05:22 EDT 2016


 You go after these things, until you realize you are making no progress,
 and are not going to, without a break.
 As of this moment, there is no conclusive fix, but a couple of things
 are now known.

 It's not Rivendell related. That's definitive.
 It is a CentOS / RHEL / GNOME thing.
 It has reared it's ugly head from time to time in various versions
 of RHEL going back some ten years, possibly more.
 It has also reared it's ugly head in various incantations of Ubuntu.

 It appears to be NFS related, but we're not certain.
 If the client is CentOS 6.8, and the server is CentOS 6.5 the problem
 does not manifest.
 An identical server but CentOS 6.4 the problem does manifest.
 If the client is CentOS 6.7 the problem does not appear at all.
 Once the NFS share is mounted, gam_server holds it. It cannot 
 be umounted without hacking gam_server.
 If NFS is never mounted, the problem doesn't manifest. ( at least
 in our test cases )

 I have a few more thoughts, but can't test them until Monday or so.
 It also appears that while gam_server will consume 100% of cpu
 when nothing else is requesting cpu, it's really more of an annoyance
 to those of us who bother to look.
 It appears to not affect the performance of Rivendell at all.
 Not by itself, anyway.

-- 
Cowboy

http://cowboy.cwf1.com

Insanity is the final defense ... It's hard to get a refund when the
salesman is sniffing your crotch and baying at the moon.


More information about the Rivendell-dev mailing list