[RDD] Appliance Versions...

Fred Gleason fredg at paravelsystems.com
Wed Jun 22 13:39:47 EDT 2016


On Jun 22, 2016, at 13:31, Seth Stevenson <rcflyer30 at gmail.com> wrote:

> Those commands didn't work for me. I think is has to do with mysql/maria and the newest version of Rivendell. Fred could you give us some help on the proper way to do an upgrade off the Appliance so that Rivendell and the database work smoothly?

All that should normally be required is doing (as root):

	yum update rivendell

The machine will need Internet access when running that command.

The only other caveat is that, if you are running multiple hosts sharing the same database, that they all be running a version that uses the same database schema.  In practice, that means that the first two digits of the Rivendell version string must be the same.  For example:

2.10.0 — 2.10.3		Same DB schema, OK to mix
2.10.3 — 2.14.0		Different DB schemas, *don’t* mix on the same system!

Cheers!


|----------------------------------------------------------------------|
| Frederick F. Gleason, Jr. |              Chief Developer             |
|                           |              Paravel Systems             |
|----------------------------------------------------------------------|
|          A room without books is like a body without a soul.         |
|                                         -- Cicero                    |
|----------------------------------------------------------------------|

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://caspian.paravelsystems.com/pipermail/rivendell-dev/attachments/20160622/d83884df/attachment.html>


More information about the Rivendell-dev mailing list