[RDD] Linker-error when building caed

Fred Gleason fredg at paravelsystems.com
Thu Jun 9 18:36:51 EDT 2016


On Jun 9, 2016, at 15:56, Marius Wikstøl <qtronix at halden.net> wrote:

> I've been struggling with compiling since v2.11.0. I think I might have messed up my environment somehow. I don't remember how I resolved it, but the problem seems to still be present.
> 
> I'm running Debian stable.

One immediate observation: looks like your configure line was:

	 $ ./configure --prefix=/usr/local --libexecdir=/var/www/html/rd-bin --with-Qt-dir=/usr/local

You’re going to want to add a ‘--sysconfdir=<conf-dir>’ switch to that.  This tells the build system where to install the Apache httpd configuration snippet.  The specific value is very distro specific; on CentOS 6/7, the correct abracadabra is ‘--sysconfdir=/etc/httpd/conf.d’.

That said, I think it’s unlikely that this was the specific cause of the linker error that you report.  The component reported as missing is shipped as part of the Rivendell source code (in ‘lib/rdwavefile.cpp’), so I tend to agree with your hypothesis that your build environment is borked somehow.

Cheers!


|----------------------------------------------------------------------|
| Frederick F. Gleason, Jr. |              Chief Developer             |
|                           |              Paravel Systems             |
|----------------------------------------------------------------------|
|          A room without books is like a body without a soul.         |
|                                         -- Cicero                    |
|----------------------------------------------------------------------|

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://caspian.paravelsystems.com/pipermail/rivendell-dev/attachments/20160609/07a21cd2/attachment.html>


More information about the Rivendell-dev mailing list