[RDD] GROUP shows in MySQL and RDAIRPLAY ADD, but not in RDLIBRARY

Robert Jeffares jeffares.robert at gmail.com
Thu Jun 2 04:25:52 EDT 2016


AUDIO_PERMS CART CLOCK_PERMS CLOCKS CUTS EVENT_PERMS EVENTS GROUPS 
REPORT_GROUPS SCHED_CODES SERVICE_PERMS SERVICES LOGS

Jarret that appears to be the solution.

Never occurred to me that the user security would replicate the groups 
but it makes absolute sense.
Have just added it in and will check after the next update.

Thanks.

Robert

On 02/06/16 16:00, Jarret Whetstone wrote:
> Hi Robert,
> I'm not sure its the cause of your problem, but it looks like the add 
> cart dialog in RDAirPlay will display all the group names for a 
> service as defined in the AUDIO_PERMS table - RDLibrary will only 
> display groups assigned to a user as granted in the USER_PERMS table.
>
> If the USER_PERMS table is not included in your sync it may explain 
> the discrepancy.
>
> Jarret
>
>
> On Wed, Jun 1, 2016 at 6:12 PM, Robert Jeffares 
> <jeffares.robert at gmail.com <mailto:jeffares.robert at gmail.com>> wrote:
>
>     I have three remote sites which run different formats using logs
>     created at a central server.
>     Each site loads it's own News Weather and other local programming.
>     An hourly data dump from MySQL is rsync-ed to each remote site and
>     inserted in the local database.
>     This is a selection of tables not the entire Rivendell database as
>     local settings like soundcard outs need to be independent.
>     Each site needs to be able to do stuff in reserved CARTS which are
>     not going to be over written by the master.
>     It's been working OK for some years.
>
>     Recently I added a GROUP which has CARTS which contain a
>     s*tatutory* announcement we are required to report broadcast times
>     for, a [random] month at a time. Report sets up on Master server
>     and runs exactly as expected and one of the options produces a
>     broadcast times but not dates report that the authority are happy
>     with.
>
>     the GROUP shows up on the master server and has been updated to
>     each of the remote sites. [MySQL enquiry confirms this]
>
>     the GROUP shows in the ADD menu in RDAIRPLAY on each remote
>
>     the GROUP does not show in the RDLIBRARY menu on each remote
>
>     checked Schema; all running 255
>
>     ran RDDBCHECK; no change <-- jolly good set of checks which found
>     a few glitches.
>
>     Much ferreting around in MySQL to see if some table in RDLIBRARY
>     needs to be included in the dump; all the ones here are there
>
>     I am at the point where I think something in the RDLIBRARY 'show
>     GROUPS' code has changed in a recent update which is a level
>     beyond my ability.
>
>     Although I am keen to learn.
>
>     There has been some tu-tu-ing in RDLIBRARY but that was around
>     multiple selection edits.
>
>     or did something get bumped?
>
>     regards
>
>     Robert Jeffares
>
>
>     -- 
>     *The Wireless Station*
>     64 Warner Park Avenue
>
>     Laingholm
>
>     Auckland 0604
>
>     09 8176358
>
>     0221693124
>
>     06 650 6087
>
>     _______________________________________________
>     Rivendell-dev mailing list
>     Rivendell-dev at lists.rivendellaudio.org
>     <mailto:Rivendell-dev at lists.rivendellaudio.org>
>     http://caspian.paravelsystems.com/mailman/listinfo/rivendell-dev
>
>

-- 
*Communication Consultants*
64 Warner Park Avenue

Laingholm

Auckland 0604

09 8176358

0221693124

06 650 6087
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://caspian.paravelsystems.com/pipermail/rivendell-dev/attachments/20160602/8bfdfd42/attachment-0001.html>


More information about the Rivendell-dev mailing list