[RDD] Mixing versions [WAS: Rivendell Missing Daemons]

Frederick Gleason fredg at paravelsystems.com
Thu May 21 06:58:01 EDT 2015


On May 20, 2015, at 15:19 57, Rob Landry <41001140 at interpring.com> wrote:

> Make sure the two versions use the same database schema. Otherwise, as Doctor Spengler might say, it would be bad.

Recent-ish versions of Rivendell (starting with v2.1.0) will in fact refuse to run if they detect that the DB version is different from the one that it knows how to use.  This is to guard against the DB corruption that can otherwise ensue by operating with mis-matched versions.

To determine which versions are ‘compatible’ DB-wise, just look at the first two numbers of the Rivendell package version.  If they are the same, then they can be safely mixed.

Some examples:

2.10.3 <=> 2.10.0	Safe to use (2.10 == 2.10)
2.9.0 <=> 2.9.1	Safe to use (2.9 == 2.9)
2.10.3 <=> 2.9.0	UNSAFE! (2.10 != 2.9)

Cheers!


|----------------------------------------------------------------------|
| Frederick F. Gleason, Jr. |              Chief Developer             |
|                           |              Paravel Systems             |
|----------------------------------------------------------------------|
|          A room without books is like a body without a soul.         |
|                                         -- Cicero                    |
|----------------------------------------------------------------------|



More information about the Rivendell-dev mailing list