[RDD] Still don't know JACK

Rob Landry 41001140 at interpring.com
Mon Jun 8 15:39:30 EDT 2015


Well, it looks like my current problem is not JACK at all but liquidsoap. 
liquidsoap doesn't appear to like Debian 8, but darkice does.

"strange errors" and segmentation faults don't happen with darkice, and 
I'm able to get Rivendell to feed darkice via JACK, and to generate a 
stream with programming on it.

Next, I need to see what I can do for audio processing.


Rob



On Mon, 8 Jun 2015, James L. Stewart wrote:

> Jack itself is ready for prime time, it is all the documentation for Jack (or 
> lack there of) which is not ready for prime time.  This is unfortunately 
> common for free open source projects.  Seems the programmers can't find the 
> time to spend to write some documentation, which isn't always a bad thing as 
> it would cut into there time spent developing.  We all can help by posting 
> our experiences getting Jack working (myself included).
>
> I have had Jack working on Rivendell and Darkice for quite some time now.  It 
> only crashed once when I ran the machine out of physical memory by 
> accidentally trying to load a huge tiff file on the workstation.  Darkice has 
> also worked perfectly for me, but last I checked the 32-bit version that is 
> compiled on the Tryphon repository still lacks Jack support (as well as 
> support for all other optional features), so I instead grabbed a compatible 
> version from Ubuntu to use on my one Debian system that is running on a 
> 32-bit (old Pentium-4) processor.
>
> So things I did was to install the optional "real time" kernel on my Debian 
> system, then carefully adjusted all the Frames/Period and Periods/buffer to 
> be stable with my hardware.  I had to dial in more latency when using our 
> Presounus USB sound device as composed to a Non USB device.  While messing 
> around with Jack on a Raspberry Pi, I had to dial in a lot of latency to get 
> it get things to work at all.
>
> Since I don't mess around with CentOS or any other OS based on Redhat 
> repositories (it seams I keep breaking them when I add other repositories to 
> try to install extra software not in the base Redhat ones) much, I won't be 
> much help with why you can't get Jack to run on it.
>
> On 6/8/2015 10:00 AM, rivendell-dev-request at lists.rivendellaudio.org wrote:
>> Date: Mon, 8 Jun 2015 09:25:41 -0400 (EDT)
>> From: Rob Landry<41001140 at interpring.com>
>> To:rivendell-dev at lists.rivendellaudio.org
>> Subject: [RDD] Still don't know JACK
>> Message-ID:<alpine.DEB.2.00.1506080919480.1618 at python.interpring.com>
>> Content-Type: TEXT/PLAIN; format=flowed; charset=US-ASCII
>> 
>> 
>> I wish there were a comprehensive guide to getting Rivendell to work with
>> JACK. I am finding JACK very frustrating and an immense time sink.
>> 
>> So far, I have managed to get it to work with Rivendell on Debian 7, but
>> not Centos 6, where JACK cannot be persuaded to start.
>> 
>> On Debian 8, JACK will start, but nothing can connect to it. Liquidsoap
>> tells me "strange error flushing buffer".
>> 
>> Methinks JACK is not ready for prime time.
>> 
>> 
>> Rob
>
> _______________________________________________
> Rivendell-dev mailing list
> Rivendell-dev at lists.rivendellaudio.org
> http://caspian.paravelsystems.com/mailman/listinfo/rivendell-dev
>


More information about the Rivendell-dev mailing list