[RDD] Streaming Troubles with edcast_jack

Joseph Matthews xcintryx at gmail.com
Thu Jan 3 17:40:54 EST 2013


How can I tell which user is "running" lame?

No, you weren't snappy, I was just frustrated at myself for forgetting the entire reason for sending that reply. I've had some crossed wires in my brain lately it would seem.

I like the idea of changing the buffer size, but I'm not sure how to do that. I thought that the 512 comes from the frames/period of 128 times four periods/buffer I tried other values for frames/period with the same result with edcast_jack ("ringbuffer full, tried to write 4096, but available 4095"). But when I change to 2 periods/buffer I get the same response ("ringbuffer full, tried to write 512, but available 511").

When I run sudo darkice I get a different output, which seems to indicate there may be a permissions problem. The output seems to show that darkice is trying to start JACK even though JACK is already running:

Using config file: /etc/darkice.cfg
Using JACK audio server as input device.
Using POSIX real-time scheduling, priority 3
Cannot connect to server socket err = No such file or directory
Cannot connect to server socket
jackdmp 1.9.6
Copyright 2001-2005 Paul Davis and others.
Copyright 2004-2010 Grame.
jackdmp comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
no message buffer overruns
no message buffer overruns
JACK server starting in realtime mode with priority 10
Failed to connect to session bus for device reservation /usr/bin/dbus-launch terminated abnormally with the following error: Autolaunch error: X11 initialization failed.


Failed to acquire device name : Audio0 error : Invalid argument
Audio device hw:0 cannot be acquired, trying to open it anyway...
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
Using ALSA driver Audigy2 running on card 0 - SB Audigy 2 ZS [SB0353] (rev.4, serial:0x10031102) at 0xcd80, irq 17
configuring for 48000Hz, period = 1024 frames (21.3 ms), buffer = 2 periods
ALSA: final selected sample format for capture: 16bit little-endian
ALSA: use 2 periods for capture
ALSA: final selected sample format for playback: 16bit little-endian
ALSA: use 2 periods for playback
Registering as JACK client darkice-3063
DarkIce: LameLibEncoder.cpp:75: lame lib opening underlying sink error [0]
JackTemporaryException : now quits...
jack main caught signal 2
Audio card Audio0 not found!!

Joey Matthews
xCinTryx at gmail.com

On Jan 3, 2013, at 3:16 PM, "Patrick Schmalstig / WRRJ Radio" <xanaftp at gmail.com> wrote:

> Okay. In that case it may be a problem with LAME. I heard sometimes it's a permissions problem... that LAME needs to run as root and for whatever reason LAME is not running as root.
> 
> Sorry if I sounded snappy when I said my question wasn't answered.
> 
> If it is a problem with LAME, possibly it's what's affecting edcast_jack as well with the incorrect buffer sizes? Just for quirks... have you tried setting buffer to 513 (haha if it's even possible)?
> 
> On Thu, Jan 3, 2013 at 4:11 PM, Joseph Matthews <xcintryx at gmail.com> wrote:
> I'm sorry! Yes, I did check and re-check the config. Everything appears to be in order.
> 
> Joey Matthews
> _______________________________________________
> Rivendell-dev mailing list
> Rivendell-dev at lists.rivendellaudio.org
> http://lists.rivendellaudio.org/mailman/listinfo/rivendell-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.rivendellaudio.org/pipermail/rivendell-dev/attachments/20130103/d12d7114/attachment.htm 


More information about the Rivendell-dev mailing list