[RDD] Fwd: Possible Bug - RDAirPlay Quitting During RDLogin User Change

Aaron Horn aaronhorn at gmail.com
Wed May 9 14:58:53 EDT 2012


Here is a YouTube video demonstrating the issue:

http://youtu.be/6-GNHYWsovg

Cheers


---------- Forwarded message ----------
From: Aaron Horn <aaronhorn at gmail.com>
Date: 9 May 2012 19:37
Subject: Possible Bug - RDAirPlay Quitting During RDLogin User Change
To: User discussion about the Rivendell Radio Automation System
<rivendell-dev at lists.rivendellaudio.org>


Hello,

I have stumbled on a bit of an issue with Rivendell 2.1.3.

I run Ubuntu Studio which is based on Ubuntu 10.04.4 LTS running the
distro build of linux 2.6.31-11-rt.

I have an AudioScience 5042 running hpklinux-4.02.11.  I have tried
compiling RD 2.1.3 against the latest hpklinux-4.10.09 but found the
compile of RD failed (this is a separate issue).

The issue I am having is that if one changes user with RDLogin whilst
RDAirPlay is playing a panel, RDAirPlay quits very soon after (not
immediately, but seemingly when the audio from the panel that was
playing ends).

I have found the following in dmesg: rdairplay[26845]: segfault at bc
ip 004aae37 sp bf8f60ac error 4 in librd-2.1.3.so[3a2000+2ac000].

I use Rivendell in a networked environment with an NFS share and MySQL
database running on a Sun server in the rack.

What I have noticed is that when I change user, the panel no longer
appears to be playing (is not red/counting down) but audio is still
coming out and the meters are still going - essentially caed is still
playing the cart out (indeed caed does not fall over and the log
indicates it is playing and then unloading the cart as per usual) but
RDAirPlay is no longer indicating this.  RDAirPlay then seemingly
dies!

I don't really know what I'm doing with gdb but here is some info that
appeared once the panel finished playing:

Program received signal SIGSEGV, Segmentation fault.
RDPlayDeck::stream (this=0x8223ee8) at rdplay_deck.cpp:286
286     {

I have compiled Rivendell from source against the current Ubuntu
10.04.4 libraries (e.g. I ran apt-get update/upgrade then compiled).

I used the following to compile:
export CXXFLAGS="-fno-stack-protector -g -O2"
export CFLAGS="-fno-stack-protector -g -O2"
./configure  --libexecdir=/usr/local/libexec --disable-jack --disable-alsa
make -j6
make install

I used the no-stack-protector option because a macro I wrote was
causing a segfault back in 1.7.2.  It may not be needed now I guess.

Any help gratefully appreciated.  I can easily replicate this issue
and it is happening in more than one of our studios.

--
Regards,
Aaron Horn,
aaronhorn at gmail.com.


-- 
Regards,
Aaron Horn,
aaronhorn at gmail.com.


More information about the Rivendell-dev mailing list