[RDD] Sound cards not available

Frederick Henderson frederickjh at gmail.com
Thu Nov 25 16:12:42 EST 2010


On Thu, 25 Nov 2010 19:54:11 +0100, John Gough <johncgough at gmail.com>  
wrote:

> Hi folks, I'm John Gough and a noob to RD and looking for some advice on
> configuring it to work with USB sound cards on RRAUbuntu 10.4 LTS. I'm  
> sure
> there's been a thousand posts on this. I tried searching the archives but
> was a slow process, is there no quick search function? I've tried the
> wiki's, RTFM and irc. But nothing yet.
>
> What I'd like to do is route Main Log output, sound panel out puts, and  
> cue
> outputs to different cards, easy eh? but they do not appear in *
> RDadmin/Hosts/Edit/AudioResources*
> *
> *
> I get this -
> *
> *
> *Card 0: hda nvidia at 0xfce 78000 irq 20*
> *Driver: ALSA*
> *In:1*
> *Out:4*
> *
> *
> *Card 1: Not present*
> *Card 2: Not Present*
> *etc.*
> *etc.
> *
> I'm using -
>
> M-audio fasttrack (USB)
> M-audio Audiophile (USB)
> Nvidia ALC888 (on board)
>
> RRABuntu
> Ubuntu 10.04 Lucid Lynx
> Athalon 2 processor
>
> I've already killed *pulseaudio* and the *autospawning* correctly.
> When I run - *rdalsaconfig *I can see all my cards in the GUI but, alas,  
> no
> joy in the RD prefs.

Hi  John Gough!

Are you running rdalsaconfig as the super user? Like this:

sudo rdalsaconfig

If not it cannot save the configuration file to /etc/asound.conf to make  
the changes when you move the new sound cards to the Active window.

You will need to restart the Rivendell daemons as well for them to see the  
change in the ALSA configuration. Do

sudo /etc/init.d/rivendell stop

then

sudo /etc/init.d/rivendell start

Check the system log for messages that may give a clue as to what is going  
on. System>Administration>Log File Viewer>messages or syslog

Also try and google your soundcard name and ALSA or ALSA and ubuntu. Here  
are a few links I found that way:

 From Googleing M-audio fasttrack (USB) ALSA ubuntu

http://ubuntu-virginia.ubuntuforums.org/showthread.php?t=1374697

http://ubuntuforums.org/archive/index.php/t-785052.html

http://ardour.org/node/744


But what was telling was a search on M-audio site. I first looked at the  
product comparison and found that linux nor ALSA was not listed but the  
ASIO driver was.

http://www.m-audio.com/images/global/howto/AudioInterfaceChart.pdf

You will want to read the article on wikipedia for lots of good info about  
it and some good links.

http://en.wikipedia.org/wiki/Audio_stream_input_output

I then headed over to M-audio support to search for linux and usb and  
found this page:

http://www.m-audio.com/index.php?do=support.faq&ID=cf6f53946a5d2cfa3792487b2af97e61

Looks like you need to get a driver for linux from opensound.com or take a  
look at the wineasio project over at sourceforge.

http://www.opensound.com/

http://www.opensound.com/wiki/index.php/Main_Page

https://sourceforge.net/projects/wineasio/


We can help see if your asound.conf file is correct. Can you post your  
/etc/asound.conf file here on the list?

If you do get it working please add a page to the wiki for M-Audio cards  
and share how you got it working for others that come after you. You could  
add a page under this section on the main page:

http://rivendell.tryphon.org/wiki/Main_Page#Sound_card_setups

or send me a write up and I can post it up.

Greetings,

Frederick Henderson

Rivendell has an irc channel for help, question and discussion too.  
#rivendell on irc.freenode.net
==================================================================================================
>
> Can someone please help?
>
> Much thanks
> John
>
> --
> John Gough


-- 
Frederick Henderson


Take the pledge!
http://www.emailetiquettepledge.com/take-the-pledge

This email sent from Opera's revolutionary e-mail client,  
http://www.opera.com/mail/
and typed on the Dvorak keyboard. http://dvzine.org

Want to learn a new language the way you learned your first?
Try LingQ for free!   ==>       http://www.lingq.com/?referral=frederickjh


More information about the Rivendell-dev mailing list