[RDD] Cannot get cron working

David Weber dweberusa at comcast.net
Mon Mar 9 15:44:26 EDT 2009


Michael wrote:
> I assume you have a script someplace to do this.  Be sure the script is
> executable by everybody.
>
> I assume you are logged in as the normal RD user.  Open a terminal
> window and enter /path/to/script.sh  and see if it runs.  If it runs OK,
> then type 'crontab -e' which will bring up the rduser's cron file.
> Assume you want to run the script at 0815 every morning.  Add the line:
> 15 08 * * * /path/to/script.sh >/dev/null 2>/dev/null
> Save the file and you should be good to go.
>
> HTH,
>
> Michael
>
> On Mon, 2009-03-09 at 15:20 -0400, David Weber wrote:
>   
>> I have tried everything to get cron working to generate logs once a day
>>
>> when I look in /var/spool/cron I see this message
>> /bin/ls cannot open directory .: permission denied
>>
>> does anyone know what I need to change to fix this
>> I have tried kcron which is  a gui  for cron
>> kcron has a run now button, when I click that button it generates a log
>>  but when I set the time and it gets to that time, it does not work
>> I have tried setting it up as root and it still does not work
>> I do not know what permissions to change to make it happy
>>
>> David Weber
>>     
>
> _______________________________________________
> Rivendell-dev mailing list
> Rivendell-dev at lists.rivendellaudio.org
> http://lists.rivendellaudio.org/mailman/listinfo/rivendell-dev
>
>   
I have done that the problem is not how I am entering it, the problem is 
I am getting
permission denied even if I try it as root  and I do not know what 
permissions I need to change

crontab 10 6 * * * /usr/local/genlog >> $home/tmp/out 2>&1

it accepts that line but it does not work because of permission problems

David Weber


More information about the Rivendell-dev mailing list