[RDD] Getting M-Audio Delta 1010 to work

Fred Gleason fredg at paravelsystems.com
Sat Nov 17 21:36:30 EST 2007


On Saturday 17 November 2007 20:11, Michael McManus wrote:
> I'm running Ubuntu 7.10 (Gutsy) and have an M-Audio Delta 1010  
> Installed. JACK appears to see the card and can start-up. However when  
> I test the sound card using the Ubuntu "Sound" Preference application  
> I can only successfully test playback; every time I try to test  
> "capture" I get the same error that tells me that gconf is failing to  
> construct a pipe. 

The 1010 has been a solid performer under Linux (and Rivendell) for years -- I 
own several myself.  One piece of advice:  if all you need to do is get sound 
into/out of Rivendell, then you'd be better off configuring it as a straight 
ALSA setup rather than using JACK.  Fewer moving parts to mess with!  See the 
'ALSA.txt' file in the Rivendell docs for details.


> I get the same error when trying to test the Intel   
> pre-installed sound card. So as far as I can tell this is system error  
> or config file problem somewhere. 

Can you do a simple recording using 'arecord'?  Something like:

	arecord -f cd test.wav


> A few other general questions. What is the best and most affordable  
> switcher to get that can interface with Rivendell? Is there a  
> Broadcast Tools model? Does anything interface via USB or is it all  
> GPIO?

Actually, everything (with the exception of a few very high-end systems like 
SAS and Logitek) use serial (COM) ports.  Most BroadcastTools models are 
supported.  See 'SWITCHERS.txt' for a list.

Cheers!


|-------------------------------------------------------------------------|
| Frederick F. Gleason, Jr. |               Chief Developer               |
|                           |               Paravel Systems               |
|-------------------------------------------------------------------------|
|    The real problem with hunting elephants is carrying the decoys.      |
|                                             -- Anonymous                |
|-------------------------------------------------------------------------|


More information about the Rivendell-dev mailing list